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ESSENTIAL OUTCOMES

8. Set various window views employing the View tab feature in Excel by:
a) [bookmark: _GoBack]Analyze skills sets provided in the Home tab handout (Worksheet Views, Show, Zoom, Window, and Macros).
b) Apply various skill set features presented in the individual ribbons. To find these skills, use the Bookmark feature.
c) Achieve industry-recognized certification, learn the computing skills companies are seeking, boost workforce resume, differentiate student from other applicants, gain valuable experience and confidence, heighten earning potential, and prepare for a successful future.
d) Apply terms in the chapter with application.


[image: ]The Focus

In Chapter 8, the focus will be on learning the skill sets that are provided underneath each of the toolbar sections for the View tab.  The focus will be on the skills sets that you need to know for certification in Microsoft Excel 2010.  There are four sections listed under the View tab.  They are as follows:

1. Worksheet Views
2. Show
3. Zoom
4. Window
5. Macros

[bookmark: _Worksheet_Views_Function][image: ]Worksheet Views Function Feature

The Worksheet Views feature provides five different types of worksheet views.  They are:

· Normal:  The Normal icon feature allows you to view a worksheet in its normal view.
· Page Layout:  The Page Layout feature allows you to view a document as it will appear on the printed page.  Use this view to see where pages begin and end, and to view any headers or footers on the page.
· Page Break Preview:  The Page Break View feature allows you to preview where pages will break when the spreadsheet is printed.
· Custom Views:  The Custom View feature provides the option to set a display and print settings as a custom view.  Once you have saved the current view, you can apply it to the document by selecting it from the list of available custom views.

[bookmark: _Show_Toolbar_Feature][image: ]Show Toolbar Feature

The Show toolbar feature enables you to change your screen in order to make reading a spreadsheet easier. For example, you may turn on or off the vertical and horizontal ruler, display or not display gridlines, remove the formula bar and headings (turns off the row and column headings).


[bookmark: _Zoom_Toolbar_Feature][image: ]Zoom Toolbar Feature

The Zoom toolbar feature is another option that enables you to change the look of your computer screen.  It allows you to open up the Zoom dialog box to specify the zoom level of the document.  You can also use the zoom controls in the status bar at the bottom of the window to quickly zoom the document.  There are three options:  Zoom, 100% and Zoom to Selection.
[image: ]
· Zoom:  The Zoom feature allows you to change the size of  your window.  
· 100%:  By selecting the 100% icon, Excel will set the window to 100% (the default setting for Excel).
· Zoom To Selection: This feature allows you to zoom the worksheet so that the currently selected range of cells fills the entire window. This can help you focus on a specific area of the spreadsheet.

[image: ]
Window Toolbar Feature 

The Window toolbar feature allows you to display sections of your worksheet, depending on what you what displayed.  There are seven options for viewing a window:
[image: ]
1. New Window:  allows you to open up the same document in a new window so that you have two of the same documents opened on the screen. 

2. [image: ]Arrange All:  options tiles all the open documents on the screen.  It will offer an option on how you want to tile the documents:  tiled, horizontally, vertically and cascading.
3. [image: ]Freeze Panes:  When your worksheet is very large and you want to return column and row headings as you work through your document without adding them to every page, use the freeze pane option.  You are given three options:  Freeze the top row, freeze the first column, or freeze panes.  The freeze pane will allow you to freeze anywhere in the spreadsheet.
4. Split:  The split option enables you to split a window into multiple resizable panes containing views of your worksheet.  You can use this feature to view multiple distant parts of your worksheet at once.
5. Hide:  Using the hide option allows you to hide specific rows and columns.  
6. Unhide:  The Unhide option allows you to re-insert hidden rows and columns.
7. Switch Windows:  Allows you to switch windows so that you can view another open spreadsheet.


Macros Toolbar Section

Do you find yourself doing the same actions over and over again in your spreadsheets?  Did you know you can create macros so that Excel can do that repetitive work for you?  Macros (use this link if you want a video explanation of macros) are sets of instructions based on actions that you record while you work in your spreadsheet. After you record a macro, you can use it again as the need arises.  Why? Because when you record a macro, Excel stores information about each step you take as you perform a series of commands. You then run the macro to repeat, or play back, the commands whenever you need them.

NOTE:  our computers at school will not retain your macro once you log off the computer. This is due to the fact that software installed on the computer automatically resets the computer to the default setting. So make sure you show me your macros before leaving class, otherwise you will have to redo them next class period.

Let’s say that every time you work in Excel, you want the “Title” style to be a set at a specific size, color, and style that is different than the default settings on the computer.  You can create a macro in Excel to do this. The macro recorder records every action you complete. Therefore, planning your macro before you begin the recording process is very important so you don't record unnecessary steps.
[bookmark: _Developer_Tab]
As an example, we want a macro that will set up the 12 months of the year going horizontally across the page that has a particular size, color and style. We can create a macro to do this for us rather than having to do it every time we open up a workbook.

[image: ]The Developer Tab

In order to utilize the “Use Relative References” for the macro, you will have to turn on the Developer Tab under the Custom Toolbar option under Options in the Backstage View (see image to the right).

[image: ]Once you have the Developer Tab selected, you will have a Developer Tab menu that will appear on the Menu bar to the right of the View menu tab. See image below.

Macros Icon
[image: ]
The Macros Icon allow you to view all of the macros that you have created in this document. It also allows you to edit a macro that you have already created (see image to the right). You can also delete a macro here as well.


To create the macro, use the following procedures:

1. [image: ]Make sure the Use Relative References is highlighted. By having this feature selected, it will not matter which row or column you used to create the macro. This feature lets the Excel know that it can be used anywhere unrelated to the cells by which is was created.
2. [image: ]Type a name for the macro in the Macro Name text box. The first character of the macro w must be a letter, and the name cannot contain spaces or cell references. Macro names are not case-sensitive. In this case we will type in FillMonthsRel.
3. Make sure that macro will be stored in “This Workbook”.
4. Click OK.
5. You are now ready to start recording your macro. Go up to the Record Macro icon in the toolbar. 
· Start your macro. Place your cursor in B4, and then type in the “January”. Use the fill series to copy the months across the column until you have all the months through December.  You will also add a Heading 1 style, change the column width to 12, add vertical and horizontal centering as well as change the font style to Times New Roman.
· Stop recording.  Once you have all of the information in your macro record, click on the “Stop Recording” icon in the Code ribbon toolbar section. 
· You will have a macro that looks like the image given below.

[image: ]






· Using your Macro: now you need to see if your macro is functional. Notice that the macro above was created in cells B4:H4. Because we made sure the “Use Cell References” icon was selected, you can put the macro anywhere in the worksheet. If we had not turned on the Use Cell Reference feature, we would only be able to put the macro in cells B4:H4. Try running your macro in A1 to see if it is functional (see image below)>

[image: ]





[bookmark: _Saving_my_Macro][bookmark: _Assigning_a_“Button”]
Custom Group on the Developer Tab
[image: ]
1. File, Options, Customize Ribbon 
2. Select “Developer” on the left side of the dialog box underneath the “Customize” ribbon tab (see red box on the right).S

3. Select “New Group” toward the bottom.
4. Click on the “Rename” icon so that you can change the icon name to “My Macros.”  See icon to the left.  NOTE:  when naming, you can put spaces between names.S

5. Click, “OK.”
6. [image: ]To add the macro to “My Macros”, select “My Group”, and then go the “Choose commands from:” on the 1st column and click on “Macros.”
7. [image: ]Scroll until you find the macro you created.  In this case, you would select “personal macro workbookfillmonthsrel”.S

8. Then select “Add”.  It will be Moved underneath the “My Macro” selection. 
9. Rename the macro “Fill Months.”  Then select the “icon” that you want to use to identify the macro.S

10. Click, “OK”.
11. [image: ]The macro icon is placed on the toolbar underneath the “Developer” tab.S

12. Place your cursor in the cell where you want to add the macro, and then click on the Fill Months icon.

[image: ]S

Customizing on the Quick Access Toolbar

1. File, Options, Quick Access Toolbar.
2. Select “Choose commands from”; then, select “Macro”.S

3. Search for your macro, select the macro and then click on “Add”.
4. The macro will move underneath the last item in the Quick Access Toolbar.
5. To rename the macro, click on “Modify” and select the icon you want to use to display the macro on the Quick Access Toolbar.
6. Click “Ok”.
7. Click “Ok” again.
8. [image: ]Go to the Quick Access Toolbar.  Place your cursor where you want to add your macro, and then select the macro icon that you just created on the Customize Toolbar. S


Editing a Macro

[image: ]Once you have created a macro, you can edit the macro to change what it does.  For example, in the macro just created, you want to change the months to numbers, and instead of the columns going horizontal across the columns., you want the months to vertically down the rows.  You could create a “new” macro, or you can build off the macro you just created by editing it manually.  S


1. Select the “Macro” icon.
2. In the “Macros in” section, select “This workbook”.
3. Then select the macro you just finished recording, “personal macro workbookfillmonthsrel”.”
4. [image: ]Then click, “Edit.”
5. This opens the Macro Special Text Editor, called the Visual Basic editor.
6. Then select the macro you want to edit. In this case, you select the second section.  Once you have selected the code, then “copy” it.S

7. Place the cursor at the end of the line, “End Sub.’  
8. Hit Enter.
9. Then paste in the code that you just copied.
10. [image: ]After copying the code, go to the first section and add a “R” at the end of the macro name (row), and go to the code you just pasted, and add a “C” at the end of the macro name (column).  The reason you adding a distinction is that macros cannot have the same names.  Since we are going to change the horizontal and vertical set up of the headings for the rows and columns, adding “R” and “C” makes sense.
11. Editing the Column Macro:
a. We want to go to the  section and select “Jan” in the C1 = “Jan” formula. (NOTE:  text is always placed n quotation marks whereas numbers are not).
b. Change the “Jan” to just the number 1. (C = 1).  Do not put quotation marks around the number.  We are changing the text to a number since we want numbers instead of text for the months.
c. [image: ]Now we need to change the “AutoFill Destination”.  In the 1st line change the (“A1,L1”) to (“A1,A12”) since we want the months to go down the columns.S

d. [image: ]Then we need to go to the next line and change the (“A1,L1”) to (“A1,A12”) as well.S

e. NOTE:  Make sure that the Type:= Type:= _ xlFillSeries” and not “Default”.
f. Close out of the Basic Editor (click on the red cross)
g. Then go to your workbook. You will see the two macros.  Use the new macro that has the “C” at the end of the macro name.

When you are done, you should be able to run both macros effectively.

[image: ]For a video presentation on this, click here.
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